re = /(\[|\G(?!\A))([^]"]*)"/m
str = '{"firstName":"Gabriela","id":9153,"language":"en","lastName":"Manriquez","login":"gmanriquez_training","profileCodes":"[role1","role2","role3","role4","role5 ]","status":"A","statusName":"Active"}
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result