using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w.*?\.\w+(?=\s)";
string input = @"00.37.jpg 00.38.jpg Convert To 3 Channels.xml Deploy All Masks.ini
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}