package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4}\.\d+|\d{4})`)
var str = `ca.2760h3x1000.5DIN345x1500e34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}