$re = '/(\d{4}\.\d+|\d{4})/m';
$str = 'ca.2760h3x1000.5DIN345x1500e34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);