import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-z])((?![A-z]{2,3}$)\\w){2,3}";
final String string = "Bt12\n"
+ "bt12\n"
+ "bte2\n"
+ "bt1\n"
+ "b123\n"
+ "b12\n\n"
+ "Bte\n"
+ "1bt\n"
+ "123\n"
+ "b1\n"
+ "abcd\n"
+ "12\n"
+ "ab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}