using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[quote\sauthor=([a-z0-9\s]+)\slink[^\]]+]";
string substitution = @"[quote=""$1""]";
string input = @"[quote author=Jeff link=topic=8576.msg32075#msg32075 date=13144659]
Moddy - does this mean various things?
[/quote]";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}