$re = '/\[quote\sauthor=([a-z0-9\s]+)\slink[^\]]+]/siU';
$str = '[quote author=Jeff link=topic=8576.msg32075#msg32075 date=13144659]
Moddy - does this mean various things?
[/quote]';
$subst = "[quote=\"$1\"]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;