$re = '/(?<!\S)[A-Za-z]+\.[A-Za-z]+(?!\S)/m';
$str = 'static.string static.mod static.bin';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);