re = /(?<!\S)[A-Za-z]+\.[A-Za-z]+(?!\S)/m
str = 'static.string static.mod static.bin'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end