re = /(\b.+?\b)\1\b/
str = 'are blue and then and then very bright
are blue and then a and then very bright'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result