package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(comment|\p{L}*vid\p{L}*|nice)`)
var str = `video-player-5681ad0a08875`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}