$re = '/(comment|\p{L}*vid\p{L}*|nice)/';
$str = 'video-player-5681ad0a08875';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);