import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(def*\\W(\\w+)([\\w\\W]*?))(?=(def)|$)";
        final String string = "def alchol_effect(self, player):\n"
	 + "    pygame.transform.rotate(player.game.window, 360)\n\n"
	 + "def hope_effect(self, player): \n"
	 + "    player.game.window.get_rect().move(0, 5)\n"
	 + "    time.sleep(0.25)\n"
	 + "    player.game.window.get_rect().move(0, -5)\n\n"
	 + "def mysterious_effect(self, player):\n"
	 + "    fun = os.path.join(\"data\", \"fun\") \n"
	 + "    temmie = get_image(os.path.join(fun, \"temmie.png\"))\n"
	 + "    temmie_sound = pygame.mixer.Sound(os.path.join(fun, \"temmie.ogg\"))\n"
	 + "    for sprite in player.game.sprites.sprites:\n"
	 + "        sprite.image = temmie\n"
	 + "    self.window.blit(temmie)\n"
	 + "    pygame.transform.rotate(player.game.window, 360*4000)";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}