const regex = /(def*\W(\w+)([\w\W]*?))(?=(def)|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(def*\\W(\\w+)([\\w\\W]*?))(?=(def)|$)', 'g')
const str = `def alchol_effect(self, player):
pygame.transform.rotate(player.game.window, 360)
def hope_effect(self, player):
player.game.window.get_rect().move(0, 5)
time.sleep(0.25)
player.game.window.get_rect().move(0, -5)
def mysterious_effect(self, player):
fun = os.path.join("data", "fun")
temmie = get_image(os.path.join(fun, "temmie.png"))
temmie_sound = pygame.mixer.Sound(os.path.join(fun, "temmie.ogg"))
for sprite in player.game.sprites.sprites:
sprite.image = temmie
self.window.blit(temmie)
pygame.transform.rotate(player.game.window, 360*4000)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}