const regex = /(?:^(?=({\w+(?1)?})$)|\G){(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?=({\\w+(?1)?})$)|\\G){(\\w+)', 'gm')
const str = `{pppppp
{a{b}}
{a{b{c}}}
{a{b{c{d}}}}
{a{bb{ccc{dd}}}}
a
{{a}
{a}}
{a}b
z{a{b}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}