$re = '/(?:^(?=({\w+(?1)?})$)|\G){(\w+)/m';
$str = '{pppppp
{a{b}}
{a{b{c}}}
{a{b{c{d}}}}
{a{bb{ccc{dd}}}}
a
{{a}
{a}}
{a}b
z{a{b}}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);