package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{0,2}[.:][0-9]{1,2}$`)
var str = `02:12
10:23
00.23
0.23
.02
:88`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}