$re = '/^[0-9]{0,2}[.:][0-9]{1,2}$/m';
$str = '02:12
10:23
00.23
0.23
.02
:88';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);