$re = '/\(.*?\)(?![^(]*\))|(?<=^| )[^\s(]+/';
$str = 'a + 4 * log(3/abs(1 – x)) + sen(-b/4 + PI)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);