re = /\(.*?\)(?![^(]*\))|(?<=^| )[^\s(]+/
str = 'a + 4 * log(3/abs(1 – x)) + sen(-b/4 + PI)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end