import re
regex = re.compile(r"\b(?=[A-Z0-9]*[A-Z])[A-Z0-9]*[0-9][A-Z0-9]*", flags=re.MULTILINE)
test_str = ("\"Please refer to reference MZ5051CLA\"\n"
"or\n"
"\"Attention for Mr Danshi, RE. 11123MTX\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")