re = /\b(?=[A-Z0-9]*[A-Z])[A-Z0-9]*[0-9][A-Z0-9]*/m
str = '"Please refer to reference MZ5051CLA"
or
"Attention for Mr Danshi, RE. 11123MTX"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end