const regex = /^((?!-([ABC])(\d{3})).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!-([ABC])(\\d{3})).)*$', 'gm')
const str = `02731043-V2024
02731043*-V2024
02731043*-I2024
3423432fffetertetg02731043*-V2024
02731043
02731043*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}