using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Invoice(\w*|-)+\.zip";
string input = @"Invoice_ref-21572989.zip";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}