package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Invoice(\w*|-)+\.zip`)
var str = `Invoice_ref-21572989.zip`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}