$re = '/(?i)(?<= |^)rum(?= |$)/m';
$str = 'I like a bit of rum with RUM my crumble pie.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);