re = /(?i)(?<= |^)rum(?= |$)/m
str = 'I like a bit of rum with RUM my crumble pie.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end