$re = '/<\s*img\s+[^>]*class=[\'"][^\'"]*game_header_image_full[^\'"]*[\'"]/i';
$str = '<img class="game_header_image_full"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);