re = /<\s*img\s+[^>]*class=['"][^'"]*game_header_image_full[^'"]*['"]/i
str = '<img class="game_header_image_full"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end