use strict;
my $str = 'Athletics, Fitted, Mesh, Feature_Moisture Wicking, Material_Polyester 100%, , Material_Polyester 100%, Material_Polyester Over 50%, School, Style_Short Sleeves, Size_2XL, Size_L, Size_M, Size_S, Size_XL, Size_XS, Size: XS-S-M-L-XL-2XL, Uniforms, Unisex, V-Neck, VisibleLogos, Youth
"Weight_8-8.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Fit_Mens, Apparel Type_Pants, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size: 32W, Size: 34W, Size: 36W, Size: 38W, Size: 40W, Size: 42W, Size: 44W, Size: 46W, Size: 48W, Size: 50W, Size: 50W-32W-34W-36W-38W-40W-42W-44W-46W-48W, Uniforms, Workwear"
"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Style_Short Sleeves, Size_2XL, Size_3XL, Size_4XL, Size_L, Size_M, Size_S, Size_XL, Uniforms, Workwear"
"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Syle_Long Sleeves, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size_2XLT, Size_LT, Size_LT-XLT-2XLT, Size_XLT, Talls, Uniforms, Workwear"
"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Syle_Long Sleeves, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size_2XL, Size_3XL, Size_4XL, Size_L, Size_M, Size_S, Size_XL, Uniforms, Workwear"
"Weight_4-4.9oz, Adult, Age_Adult, Material_Cotton 100%, Feature_Cotton-Combed, Feature_Ringspun Cotton, Collar Style_Crewneck, Jersey, Fit_Juniors, Weight_Light(Under 5 oz), Material_Cotton 100%, Feature_No Visible Logos, Style_Short Sleeves, Feature_Side Seams, Feature_Side Seams, Size_2XL, Size_3XL, Size_L, Size_M, Size_S, Size_XL, Tag Style_Tear Away, Feature_USA Made, Womens"
"Product Type_Accessories, Size_Adjustable, Adult, Age_Adult, Feature_American Made, Material_Cotton 100%, Material_Cotton Over 50%, Embroidered, GarmentWashed, Product Type_Headwear, Hat Styles_Low Profiles, Material_Cotton 100%, Feature_No Visible Logos, Hat Style_Pre-Curved Visor, Hat Style_Six Panel, Size_Size_Adjustable, UnHat Style_Structured, Feature_USA Certified, USAMade"
"Product Type_Accessories, Size_Adjustable, Adult, Age_Adult, Feature_American Made, Material_Cotton 100%, Material_Cotton Over 50%, Embroidered, GarmentWashed, Product Type_Headwear, Hat Styles_Low Profiles, Material_Cotton 100%, Feature_No Visible Logos, Hat Style_Pre-Curved Visor, Style_Relaxed, Hat Style_Six Panel, Size_Size_Adjustable, UnHat Style_Structured, Feature_USA Certified, USAMade"
Size: 30W-40W,';
my $regex = qr/Size: (?:\d*X[SL]|L|M|S|\d+W)(?:-(?:\d*X[LS]|L|M|S|\d+W))*,/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}