import re
regex = re.compile(r"Size: (?:\d*X[SL]|L|M|S|\d+W)(?:-(?:\d*X[LS]|L|M|S|\d+W))*,", flags=re.MULTILINE)
test_str = ("Athletics, Fitted, Mesh, Feature_Moisture Wicking, Material_Polyester 100%, , Material_Polyester 100%, Material_Polyester Over 50%, School, Style_Short Sleeves, Size_2XL, Size_L, Size_M, Size_S, Size_XL, Size_XS, Size: XS-S-M-L-XL-2XL, Uniforms, Unisex, V-Neck, VisibleLogos, Youth\n\n"
"\"Weight_8-8.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Fit_Mens, Apparel Type_Pants, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size: 32W, Size: 34W, Size: 36W, Size: 38W, Size: 40W, Size: 42W, Size: 44W, Size: 46W, Size: 48W, Size: 50W, Size: 50W-32W-34W-36W-38W-40W-42W-44W-46W-48W, Uniforms, Workwear\"\n\n"
"\"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Style_Short Sleeves, Size_2XL, Size_3XL, Size_4XL, Size_L, Size_M, Size_S, Size_XL, Uniforms, Workwear\"\n\n"
"\"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Syle_Long Sleeves, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size_2XLT, Size_LT, Size_LT-XLT-2XLT, Size_XLT, Talls, Uniforms, Workwear\"\n\n"
"\"Weight_5-5.9oz, Adult, Age_Adult, Feature_Cotton-Combed, Embroidered, Syle_Long Sleeves, Fit_Mens, Feature_Pockets, Material_Polyester 100%, , Material_Polyester Over 50%, Size_2XL, Size_3XL, Size_4XL, Size_L, Size_M, Size_S, Size_XL, Uniforms, Workwear\"\n\n"
"\"Weight_4-4.9oz, Adult, Age_Adult, Material_Cotton 100%, Feature_Cotton-Combed, Feature_Ringspun Cotton, Collar Style_Crewneck, Jersey, Fit_Juniors, Weight_Light(Under 5 oz), Material_Cotton 100%, Feature_No Visible Logos, Style_Short Sleeves, Feature_Side Seams, Feature_Side Seams, Size_2XL, Size_3XL, Size_L, Size_M, Size_S, Size_XL, Tag Style_Tear Away, Feature_USA Made, Womens\"\n\n"
"\"Product Type_Accessories, Size_Adjustable, Adult, Age_Adult, Feature_American Made, Material_Cotton 100%, Material_Cotton Over 50%, Embroidered, GarmentWashed, Product Type_Headwear, Hat Styles_Low Profiles, Material_Cotton 100%, Feature_No Visible Logos, Hat Style_Pre-Curved Visor, Hat Style_Six Panel, Size_Size_Adjustable, UnHat Style_Structured, Feature_USA Certified, USAMade\"\n\n"
"\"Product Type_Accessories, Size_Adjustable, Adult, Age_Adult, Feature_American Made, Material_Cotton 100%, Material_Cotton Over 50%, Embroidered, GarmentWashed, Product Type_Headwear, Hat Styles_Low Profiles, Material_Cotton 100%, Feature_No Visible Logos, Hat Style_Pre-Curved Visor, Style_Relaxed, Hat Style_Six Panel, Size_Size_Adjustable, UnHat Style_Structured, Feature_USA Certified, USAMade\"\n\n\n\n\n\n"
"Size: 30W-40W,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")