#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(<tr>\s*(<th>((?!<tr>).)*</th>)+\s*</tr>)"
Local $sString = "<table>" & @CRLF & _
"<tr>" & @CRLF & _
" <th>header21</th> " & @CRLF & _
" <th>header22</th>" & @CRLF & _
" <th>header23</th>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td>body1</td> " & @CRLF & _
" <td>body2</td>" & @CRLF & _
" <td>body3</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"<table>" & @CRLF & _
"<tr>" & @CRLF & _
" <th>header21</th> " & @CRLF & _
" <th>header22</th>" & @CRLF & _
" <th>header23</th>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td>body1</td> " & @CRLF & _
" <td>body2</td>" & @CRLF & _
" <td>body3</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")