import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<tr>\\s*(<th>((?!<tr>).)*</th>)+\\s*</tr>)";
final String string = "<table>\n"
+ "<tr>\n"
+ " <th>header21</th> \n"
+ " <th>header22</th>\n"
+ " <th>header23</th>\n"
+ "</tr>\n"
+ "<tr>\n"
+ " <td>body1</td> \n"
+ " <td>body2</td>\n"
+ " <td>body3</td>\n"
+ "</tr>\n"
+ "</table>\n"
+ "<table>\n"
+ "<tr>\n"
+ " <th>header21</th> \n"
+ " <th>header22</th>\n"
+ " <th>header23</th>\n"
+ "</tr>\n"
+ "<tr>\n"
+ " <td>body1</td> \n"
+ " <td>body2</td>\n"
+ " <td>body3</td>\n"
+ "</tr>\n"
+ "</table>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}