package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(\+\/-\s*\d+)|((\+\s*\d+)\s*\/\s*(-\s*\d+)))$`)
var str = `+/-90000
+9000 / -80000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}