re = /^(?:(\+\/-\s*\d+)|((\+\s*\d+)\s*\/\s*(-\s*\d+)))$/m
str = '+/-90000
+9000 / -80000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end