const regex = /^(\w+): (\d) \((\d{2}\.\d{2}%)\)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+): (\\d) \\((\\d{2}\\.\\d{2}%)\\)$', '')
const str = `Positive: 3 (60.00%)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}