package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)# Adding password requirements are as easy as tacking on
# another (?=...) group.
^
(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter
(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters
(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits
(?=(?:[^\s]*[\s]){1}) # At least {1} whitespace
(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char
(?=.{9}) # A minimum of 9 characters
`)
var str = `See 'unit tests' to see all matching/non-matching examples.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}