use strict;
my $str = 'See \'unit tests\' to see all matching/non-matching examples.
';
my $regex = qr/# Adding password requirements are as easy as tacking on
# another (?=...) group.
^
(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter
(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters
(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits
(?=(?:[^\s]*[\s]){1}) # At least {1} whitespace
(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char
(?=.{9}) # A minimum of 9 characters
/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}