#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<text1>[^\r\n:]+)\s:\s*ProgID\s:\s(?<text2>[^\r\n]+)"
Local $sString = "Outlook a désactivé le ou les compléments suivants :" & @CRLF & _
"ProgID : ColleagueImport.ColleagueImportAddin" & @CRLF & _
"GUID : {EFEF7FDB-0CED-4FB6-B3BB-3C50D39F4120}" & @CRLF & _
"Nom : Microsoft SharePoint Server Colleague Import Add-in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")