import re
regex = re.compile(r"(?<text1>[^\r\n:]+)\s:\s*ProgID\s:\s(?<text2>[^\r\n]+)", flags=re.MULTILINE)
test_str = ("Outlook a désactivé le ou les compléments suivants :\n"
"ProgID : ColleagueImport.ColleagueImportAddin\n"
"GUID : {EFEF7FDB-0CED-4FB6-B3BB-3C50D39F4120}\n"
"Nom : Microsoft SharePoint Server Colleague Import Add-in")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")