package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?(?:\d+)?\.?\d+)`)
var str = `M0.286-3.099-0.44c-2.901,-0.436,,,123,0.123,.34.34.34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}