const regex = /([-+]?(?:\d+(?:\.\d*)?|\.\d+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-+]?(?:\\d+(?:\\.\\d*)?|\\.\\d+))', 'g')
const str = `M0.286-3.099-0.44c-2.901,-0.436,,,123,0.123,.34.34.34m23.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}