// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([-+]?(?:\d+(?:\.\d*)?|\.\d+))").unwrap();
let string = "M0.286-3.099-0.44c-2.901,-0.436,,,123,0.123,.34.34.34m23.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}