use strict;
my $str = '<document id=\'3316200\' srcDocId=\'http://ecx.images-amazon.com/images/I/61A9A0fmN7L.jpg\'</document>
<document id=\'3306829\' srcDocId=\'http://ecx.images-amazon.com/images/I/71sQDUoJbmL.jpg\'</document>
<document id=\'2406251\' srcDocId=\'http://ecx.images-amazon.com/images/I/71j7ISxAOdL.jpg\'</document>
<document id=\'2534144\' srcDocId=\'http://ecx.images-amazon.com/images/I/71VXMXcrg2L.jpg\'</document>
<document id=\'3417415\' srcDocId=\'http://ecx.images-amazon.com/images/I/71Ymoo32gVL.jpg\'</document>';
my $regex = qr/(id='.*?') (srcDocId='.*?')/ip;
my $subst = '$1 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";