$re = '/(id=\'.*?\') (srcDocId=\'.*?\')/i';
$str = '<document id=\'3316200\' srcDocId=\'http://ecx.images-amazon.com/images/I/61A9A0fmN7L.jpg\'</document>
<document id=\'3306829\' srcDocId=\'http://ecx.images-amazon.com/images/I/71sQDUoJbmL.jpg\'</document>
<document id=\'2406251\' srcDocId=\'http://ecx.images-amazon.com/images/I/71j7ISxAOdL.jpg\'</document>
<document id=\'2534144\' srcDocId=\'http://ecx.images-amazon.com/images/I/71VXMXcrg2L.jpg\'</document>
<document id=\'3417415\' srcDocId=\'http://ecx.images-amazon.com/images/I/71Ymoo32gVL.jpg\'</document>';
$subst = "$1 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;