using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?![:[\];|\\=,\/+*?<>""])[ -~]){1,25}$";
string input = @"Abc 123
Abc_345
""Abc_345""
'Abc_345'
Abc=345
Abc_345:
Abc_345[
Abc_345]
Abc_345;
Abc_345|
Abc_345\
Abc_345=
Abc_345,
Abc_345/
Abc_345+
Abc_345*
Abc_345?
Abc_345<
Abc_345>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}