$re = '/^(?:(?![:[\];|\\\\=,\/+*?<>"])[ -~]){1,25}$/m';
$str = 'Abc 123
Abc_345
"Abc_345"
\'Abc_345\'
Abc=345
Abc_345:
Abc_345[
Abc_345]
Abc_345;
Abc_345|
Abc_345\\
Abc_345=
Abc_345,
Abc_345/
Abc_345+
Abc_345*
Abc_345?
Abc_345<
Abc_345>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);