$re = '/^\s*(\d+(?:\.\d+)?)(?:\s*\-\s*(\d+(?:\.\d+)?))?\s*$/';
$str = ' 1.000 - 2 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);