package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\{(.*?)\}`)
var str = `Hello, My name is {NAMES.ID1} and I am {USER.age} and I do {HOBBY.NAME}.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}