$re = '/\{(.*?)\}/i';
$str = 'Hello, My name is {NAMES.ID1} and I am {USER.age} and I do {HOBBY.NAME}.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);